Pending processing of NGN payouts to Kuda, Eyowo, Jaiz Bank, PalmPay, Taj and PayCom
Incident Report for Eversend
Resolved
This issue has been resolved.
Posted Apr 17, 2024 - 09:24 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 16, 2024 - 08:29 UTC
This incident affected: Transfers (Sending and receiving money) (Sending money to Nigeria (bank account)).